Skip to main content
CVE-2026-80212VulnerabilityPublished

Red Hat Security Advisory: ruby:2.5 security update

Affects Red Hat ruby:2.5Source GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-80212· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade Red Hat ruby:2.5 to 0.7.2 or 0.3.2 soon.

Data as of 6 Nov 2026, 07:47 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.7.2, 0.3.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade resolv to 0.7.2 or 0.3.2.

Affected software

ProductAffectedFixed in
RubyresolvAffected
  • >=0.4.0 <0.7.2
Fixed in
  • 0.7.2
RubyresolvAffected
  • <0.3.2
Fixed in
  • 0.3.2

AI-suggested

Red Hat has released updated ruby:2.5 packages for Red Hat Enterprise Linux 8.6 that fix these vulnerabilities. Users should apply the security update as described in Red Hat advisory RHSA-2026:95513 and the linked article https://access.redhat.com/articles/11258. No additional mitigation steps are indicated by the vendor advisory. Systems updated with the provided packages are considered remediated.

Description

Red Hat issued a security advisory for ruby:2.5 addressing two vulnerabilities: CVE-2026-80212 and CVE-2026-88030. The first is a denial of service vulnerability in the resolv gem caused by uncontrolled memory growth from crafted DNS responses. The second affects the MongoDB Ruby Driver (rubygem-mongo) and allows data disclosure and denial of service via query-operator injection. These issues impact Red Hat Enterprise Linux 8.6 versions with ruby:2.5 modules. The advisory rates the update as Important and provides updated packages to fix these vulnerabilities.

References

Community reviews

Loading reviews…