Red Hat Security Advisory: Satellite 6.16.5.5 Async Update
Affects Red HatSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 8.0 High.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 5 Nov 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Red Hatredhat/foremanpkg:rpm/redhat/foremanOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Red Hat Satellite to version 6.16.5.5 or later, which contains fixes for these vulnerabilities. Before applying this update, ensure all previously released errata relevant to the system have been applied. Follow Red Hat's official guidance on applying updates as detailed in their advisory. No additional mitigation steps are indicated beyond applying the official patches.
Description
Red Hat Satellite 6.16.5.5 addresses multiple security issues including an OS command injection vulnerability in foreman via ct_location and fcct_location parameters (CVE-2025-10622), and two vulnerabilities in rubygem-rack involving unbounded read leading to memory exhaustion (CVE-2025-61919) and a params_limit bypass via semicolon-separated parameters (CVE-2025-59830). These issues are fixed in the updated packages for Red Hat Satellite 6.16 for RHEL 8 and 9. Users are advised to upgrade to the fixed versions to mitigate these vulnerabilities.
References
- access.redhat.com/errata/RHSA-2025:19855 (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2396020 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2398167 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2403180 (opens in a new tab)
- issues.redhat.com/browse/SAT-39698 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2025/rhsa-2025_19855.json (opens in a new tab)