Skip to main content
CVE-2026-42561VulnerabilityPublished Updated

Red Hat Security Advisory: satellite/iop-vulnerability-engine-rhel9 container image available as a Technology Preview

Affects Red Hat python-multipartSource GCVE Database

0
Compare
Authoritative record:CVE-2026-42561· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade Red Hat python-multipart to 1.40.0 soon.

Data as of 6 Nov 2026, 23:24 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.40.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade kimi-cli to 1.40.0.

Affected software

ProductAffectedFixed in
PyPIpython-multipartpkg:pypi/python-multipartOther threatsAffected
  • *
Fixed in–
Homebrewkimi-clipkg:brew/kimi-cliOther threatsAffected
  • >=0.40 <1.40.0
Fixed in
  • 1.40.0
Ubuntu Pro 22.04 LTSpython-multipartpkg:deb/ubuntu/python-multipart?arch=source&distro=esm-apps/jammyOther threatsAffected
  • =0.0.5-2
  • =0.0.5-2ubuntu0.1~esm1
Fixed in–
Ubuntu Pro 24.04 LTSpython-multipartpkg:deb/ubuntu/python-multipart?arch=source&distro=esm-apps/nobleOther threatsAffected
  • 0.0.5-3 – 0.0.9-1ubuntu0.1~esm1
4 affected builds
Fixed in–
Ubuntu 25.10python-multipartpkg:deb/ubuntu/python-multipart?arch=source&distro=questingOther threatsAffected
  • =0.0.20-1
Fixed in–
Ubuntu 26.10python-multipartpkg:deb/ubuntu/python-multipart?arch=source&distro=stonkingOther threatsAffected
  • =0.0.20-1.1
  • =0.0.26-1
  • =0.0.32-1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade python-multipart to version 0.0.27 or later to fully mitigate the vulnerability. If upgrading immediately is not feasible, implement request body size limits at the server or proxy to reduce exposure, but note this does not fully fix the issue.

Description

A denial of service vulnerability exists in the python-multipart library used for parsing multipart/form-data requests. The flaw allows an attacker to cause excessive CPU usage by sending requests with many repeated headers without termination or a single very large header value. This affects ASGI applications using frameworks like Starlette or FastAPI that rely on python-multipart. The issue is mitigated by upgrading to python-multipart version 0.0.27 or later. If immediate upgrade is not possible, limiting request body size at the server or proxy can reduce exposure but does not fully resolve the vulnerability.

References

Community reviews

Loading reviews…