Skip to main content
CVE-2026-78679VulnerabilityPublished Updated

Red Hat Security Advisory: satellite/iop-vulnerability-engine-rhel9 container image available as a Technology Preview

Affects Red HatSource GCVE Database

0
Compare
Authoritative record:CVE-2026-78679· High 7.1

Not known to be exploited · CVSS 7.1 High : upgrade Red Hat gitpython to 3.1.59 soon.

Data as of 30 Oct 2026, 00:05 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.1.59
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade GitPython and gitpython to 3.1.59.

Affected software

ProductAffectedFixed in
gitpython-developersGitPythonAffected
  • <3.1.59
Fixed in
  • 3.1.59
PyPIgitpythonpkg:pypi/gitpythonOther threatsAffected
  • <3.1.59
Fixed in
  • 3.1.59

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat currently does not offer a patch or mitigation that meets their criteria for ease of use, deployment, or applicability. If you cannot patch yet, avoid exposing the vulnerable code path to untrusted input. Refer to the upstream advisory at https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-3wxw-xv34-2frg for additional information.

Description

A vulnerability (CVE-2026-78679) exists in GitPython's TagReference.create() function, where an incomplete fix for a prior issue allows a low-privilege remote attacker to supply a specially crafted reference parameter. This can lead to arbitrary file read on the system, exposing file contents within annotated tag messages and causing information disclosure. The vulnerability affects applications that forward user-controlled input to this function. The vulnerability is related to Red Hat Satellite's Red Hat Lightspeed component, which analyzes system health locally.

References

Community reviews

Loading reviews…