Skip to main content
CVE-2026-0719VulnerabilityPublished Updated

Red Hat Security Advisory: spice-client-win security update

Affects Red Hat spice-client-winSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2026-0719· High 8.6

Not known to be exploited · CVSS 8.6 High : upgrade the Red Hat redhat/libsoup package to 9.2.10 or 8.8.8 soon.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.2.10, 8.8.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/libsoup package to 9.2.10 or 8.8.8.

Affected software

ProductAffectedFixed in
Red Hatredhat/libsouppkg:rpm/redhat/libsoupOther threatsAffected
  • >=8.8 <8.8.8
  • >=9.2 <9.2.10
Fixed in
  • 8.8.8
  • 9.2.10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released security updates addressing these vulnerabilities in spice-client-win packages for Red Hat Enterprise Linux 8.8 variants. Users should apply the updates as described in the Red Hat advisory RHSA-2026:2528 and the referenced article https://access.redhat.com/articles/11258. There is no indication that no action is required; therefore, applying the official patches is the recommended mitigation. Patch status is confirmed by the vendor advisory.

Description

This advisory addresses two stack-based buffer overflow vulnerabilities in libsoup used by spice-client-win MSI installers for Windows clients. The first vulnerability (CVE-2026-0719) involves a signed to unsigned conversion error in NTLM authentication, and the second (CVE-2026-1761) concerns multipart HTTP response parsing. These issues could lead to memory corruption. Red Hat has issued security updates for spice-client-win on Red Hat Enterprise Linux 8.8 variants to fix these vulnerabilities.

References

Community reviews

Loading reviews…