Red Hat Security Advisory: tomcat security update
Affects Red Hat tomcatSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 7.5 High : upgrade the Red Hat redhat/tomcat package to 8.10.2 soon.
Data as of 27 Oct 2026, 05:11 UTC
- EPSS
- 4.6% chance of exploitation in 30 days – higher than 91% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.10.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 3 Jul 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the Red Hat redhat/tomcat package to 8.10.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Red Hatredhat/tomcatpkg:rpm/redhat/tomcatOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Red Hat has released updated Tomcat packages (version 9.0.87-1.el8_10.2) that address these vulnerabilities. Users of affected Red Hat Enterprise Linux 8 systems should apply the security update as detailed in Red Hat advisory RHSA-2024:5694. For instructions on applying the update, refer to https://access.redhat.com/articles/11258. No additional mitigation steps are indicated by the vendor.
Description
Red Hat has issued a security advisory for Apache Tomcat addressing two vulnerabilities: CVE-2024-34750, involving improper handling of exceptional conditions, and CVE-2024-38286, a denial of service vulnerability. These issues affect Red Hat Enterprise Linux 8 versions prior to 8.10.2. The update is rated as important by Red Hat Product Security. A patch is available to remediate these vulnerabilities.
References
- access.redhat.com/errata/RHSA-2024:5694 (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2295651 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2314686 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2024/rhsa-2024_5694.json (opens in a new tab)