Skip to main content
CVE-2024-34750VulnerabilityPublished Updated

SUSE · security update for tomcat

Affects SUSESource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2024-34750· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 9.0.87 soon.

Data as of 26 Oct 2026, 07:57 UTC

CVSS base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
4.6% chance of exploitation in 30 days – higher than 91% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.0.87

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Jul 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade redhat/tomcat to 9.0.87.

Affected software

ProductAffectedFixed in
Red Hatredhat/tomcatpkg:rpm/redhat/tomcatOther threatsAffected
  • <9.0.87
Fixed in
  • 9.0.87

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available and should be applied promptly to affected Apache Tomcat installations. Vendors such as Red Hat and SUSE have released patches addressing these vulnerabilities. Refer to the official vendor advisories and update instructions (e.g., Red Hat advisory RHSA-2024:5693 and SUSE security updates) to apply the fixes. No additional mitigation steps are indicated beyond applying the official patches.

Description

Multiple security vulnerabilities have been identified and fixed in Apache Tomcat, a widely used servlet container for Java Servlet and JavaServer Pages technologies. These issues include improper input validation, authentication bypasses, HTTP/2 header validation flaws, information disclosure, improper authorization, case sensitivity handling errors, security constraint bypasses, and insufficient documentation that may lead to insecure configurations. The vulnerabilities affect various components such as tomcat-coyote and tomcat-catalina. A security update addressing these vulnerabilities is available for affected versions, including those distributed with Red Hat Enterprise Linux and SUSE. The update is rated as important/high severity by vendors. No known exploits are reported in the wild at this time.

References

Community reviews

Loading reviews…