Skip to main content
CVE-2024-29038VulnerabilityPublished Updated

SUSE tpm2-tools · security update for tpm2-tools

Affects SUSE tpm2-toolsSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2024-29038· Medium 4.3

Not known to be exploited · CVSS 4.3 Medium : upgrade the Red Hat redhat/tpm2-tools package to 9.5.0 when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.5.0
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Jun 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/tpm2-tools package to 9.5.0.

Affected software

ProductAffectedFixed in
Red Hatredhat/tpm2-toolspkg:rpm/redhat/tpm2-toolsOther threatsAffected
  • <9.5.0
Fixed in
  • 9.5.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available from Red Hat for the tpm2-tools package on Red Hat Enterprise Linux 9. Users should apply the update as per Red Hat's advisory RHSA-2024:9424 to remediate these vulnerabilities. No additional mitigation actions are specified or required beyond applying the official patch.

Description

Two security vulnerabilities were identified in the tpm2-tools package used on Red Hat Enterprise Linux 9. The first vulnerability (CVE-2024-29038) allows arbitrary quote data to go undetected by the tpm2_checkquote utility. The second vulnerability (CVE-2024-29039) involves the PCR selection value not being compared with the attest, potentially undermining integrity checks. Red Hat has issued a security update addressing these issues with a low severity rating. The update is available for multiple Red Hat Enterprise Linux 9 variants and architectures.

References

Community reviews

Loading reviews…