SUSE · security update for vim
Affects SUSESource GCVE Database
Mentioned vulnerabilities
Not known to be exploited : upgrade to 9.9.0 when convenient.
Data as of 25 Oct 2026, 19:02 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.9.0
Exploitation evidence
Disclosed: evidence found.
CVE published 13 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade SUSE to 9.9.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SUSE Product Security Team SUSE | Affected
| Fixed in
|
AI-suggested
Red Hat has released updated Vim packages that fix these path traversal vulnerabilities. Users of affected Red Hat Enterprise Linux 9 versions (>=9.0.0 and <9.9.0) should apply the security update as described in the Red Hat advisory RHSA-2025:17742 and the update instructions at https://access.redhat.com/articles/11258. Applying the official update fully mitigates the vulnerabilities.
Description
Red Hat has issued a security advisory for Vim addressing two path traversal vulnerabilities identified as CVE-2025-53905 and CVE-2025-53906. These vulnerabilities affect Vim versions included in Red Hat Enterprise Linux 9, specifically versions from 9.0.0 up to but not including 9.9.0 across multiple architectures. The security impact is rated as moderate. Red Hat has released updates to fix these issues and provides guidance on applying the update.
Reports on CVE-2025-53905
References
- access.redhat.com/errata/RHSA-2025:17742 (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2380360 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2380362 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2025/rhsa-2025_17742.json (opens in a new tab)
- suse.com/support/security/rating/ (opens in a new tab)
- ftp.suse.com/pub/projects/security/csaf/rhsa-2025_17742.json (opens in a new tab)
- lists.suse.com/pipermail/suse-liberty-linux-updates/2025-October/002089.html (opens in a new tab)
- suse.com/security/cve/CVE-2025-53905/ (opens in a new tab)
- suse.com/security/cve/CVE-2025-53906/ (opens in a new tab)