Skip to main content
CVE-2025-31205VulnerabilityPublished Updated

Red Hat Security Advisory: webkit2gtk3 security update

Affects Red Hat webkit2gtk3Source GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited : upgrade the Red Hat redhat/webkit2gtk3 package to 8.4.2 soon.

Data as of 26 Oct 2026, 08:30 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.4.2

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/webkit2gtk3 package to 8.4.2.

Affected software

ProductAffectedFixed in
Red Hatredhat/webkit2gtk3pkg:rpm/redhat/webkit2gtk3Other threatsAffected
  • =8.4
  • <8.4.2
Fixed in
  • 8.4.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated webkit2gtk3 packages for Red Hat Enterprise Linux 8.4 to address these vulnerabilities. Users should apply this security update promptly after ensuring all prior relevant errata are installed. No additional mitigations are specified or required beyond applying the official update. Patch status is confirmed by the Red Hat advisory RHSA-2025:8530.

Description

Red Hat has issued a security advisory for webkit2gtk3 addressing two vulnerabilities in WebKitGTK, the WebKit port for GTK. The first vulnerability (CVE-2025-31205) allows a malicious website to exfiltrate data across origins. The second (CVE-2025-31257) can cause an unexpected crash in Safari when processing maliciously crafted web content. These issues have been rated as important by Red Hat. An update is available for affected Red Hat Enterprise Linux 8.4 variants to remediate these vulnerabilities.

References

Community reviews

Loading reviews…