Skip to main content
CVE-2025-3155VulnerabilityPublished Updated

Red Hat Security Advisory: yelp security update

Affects Red Hat yelpSource GCVE Database

0
Compare
Authoritative record:CVE-2025-3155· High 7.4

Not known to be exploited · CVSS 7.4 High : upgrade the Red Hat redhat/yelp package to 3.28.1-3.el8_2.1 soon.

Data as of 3 Nov 2026, 20:33 UTC

CVSS 3.1 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.17.4
Patch
Available – fixed in 3.28.1-3.el8_2.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Apr 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade the Red Hat redhat/yelp package to 3.28.1-3.el8_2.1.

Affected software

ProductAffectedFixed in
Red Hatredhat/yelppkg:rpm/redhat/yelpOther threatsAffected
  • <3.28.1-3.el8_2.1
Fixed in
  • 3.28.1-3.el8_2.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released a security update for Yelp in Red Hat Enterprise Linux 8.2 AUS, version 3.28.1-3.el8_2.1, which fixes the arbitrary file read vulnerability (CVE-2025-3155). Users should apply this update promptly following the instructions in the Red Hat advisory (https://access.redhat.com/articles/11258). No additional mitigation steps are indicated beyond applying the official patch.

Description

A security vulnerability identified as CVE-2025-3155 affects Yelp, the help browser for the GNOME desktop used in Red Hat Enterprise Linux 8.2 AUS. The flaw allows arbitrary file read, which could expose sensitive information. Red Hat has issued an important security update addressing this issue in Yelp version 3.28.1-3.el8_2.1. Users of the affected Red Hat Enterprise Linux version should apply the update to mitigate the risk.

References

Community reviews

Loading reviews…