Skip to main content
VulnerabilityPublished Updated

CVE-2024-0520: Remote Code Execution due to Full Controlled File Write in mlflow/mlflow

Affects mlflowSource GCVE Database

0
Authoritative record:CVE-2024-0520· Critical 10.0

Not known to be exploited · CVSS 10.0 Critical : upgrade to 2.9.1 as a priority.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.0 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
2.4% chance of exploitation in 30 days – higher than 83% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.9.1
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Jun 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade mlflow to 2.9.1.

Affected software

ProductAffectedFixed in
Bitnamimlflowpkg:bitnami/mlflowOther threatsAffected
  • <2.9.1
Fixed in
  • 2.9.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and the vulnerability is fixed in mlflow version 2.9.0. Users should upgrade to version 2.9.0 or later to remediate this issue. No additional mitigation steps are indicated by the vendor advisory.

Description

A critical remote code execution vulnerability exists in mlflow versions prior to 2.9.1. The flaw arises from improper sanitization of filenames derived from HTTP Content-Disposition headers or URL paths when loading datasets, allowing attackers to perform arbitrary file writes via path traversal or absolute paths. This can lead to execution of malicious commands on the affected system. The issue is fixed in version 2.9.0.

References

Community reviews

Loading reviews…