Skip to main content
VulnerabilityPublished

CVE-2026-36453: Rhymix before 2.1.31 allows insecure direct object reference, aka RVE-2026-1

Affects rhymixSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.4 High : upgrade to 2.1.31 soon.

Data as of 29 Oct 2026, 07:15 UTC

CVSS 3.1 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.1.31
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade rhymix/rhymix to 2.1.31.

Affected software

ProductAffectedFixed in
GitHubrhymix/rhymixpkg:github/rhymix/rhymixOther threatsAffected
  • <2.1.31
Fixed in
  • 2.1.31

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Rhymix version 2.1.31. Users should upgrade to version 2.1.31 or later to remediate this vulnerability. No additional mitigation guidance is provided, and patching is the recommended action.

Description

Rhymix before 2.1.31 allows insecure direct object reference, aka RVE-2026-1. Arbitrary files can be accessed via extra variables.

References

Community reviews

Loading reviews…