Skip to main content
VulnerabilityPublished

CVE-2026-54432: Roundcube Webmail before 1.6.17 and 1.7.x before 1.7.2 allows Stored Cross-Site Scripting (XSS)

Affects roundcubeSource GCVE Database

0
Authoritative record:CVE-2026-54432· Medium 4.7

Not known to be exploited · CVSS 4.7 Medium · fixed in 1.6.17 : update roundcube when convenient.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
4.7Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.6.17
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10roundcubepkg:deb/ubuntu/roundcube?arch=source&distro=stonkingOther threatsAffected
  • =1.6.11+dfsg-1
Fixed in–
Ubuntu Pro 26.04 LTSroundcubepkg:deb/ubuntu/roundcube?arch=source&distro=esm-apps/resoluteOther threatsAffected
  • =1.6.11+dfsg-1
  • =1.6.11+dfsg-1ubuntu0.26.04.1~esm1
Fixed in–
Ubuntu 25.10roundcubepkg:deb/ubuntu/roundcube?arch=source&distro=questingOther threatsAffected
  • =1.6.10+dfsg-1
  • =1.6.10+dfsg-2
  • =1.6.11+dfsg-1
Fixed in–
Ubuntu Pro 24.04 LTSroundcubepkg:deb/ubuntu/roundcube?arch=source&distro=esm-apps/nobleOther threatsAffected
  • 1.6.2+dfsg-1 – 1.6.6+dfsg-2ubuntu0.1+esm3
9 affected builds
Fixed in–
Ubuntu Pro 22.04 LTSroundcubepkg:deb/ubuntu/roundcube?arch=source&distro=esm-apps/jammyOther threatsAffected
  • 1.4.11+dfsg.1-4 – 1.5.0+dfsg.1-2ubuntu0.1~esm6
8 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSroundcubepkg:deb/ubuntu/roundcube?arch=source&distro=esm-apps/focalOther threatsAffected
  • 1.3.8+dfsg.1-2 – 1.4.3+dfsg.1-1ubuntu0.1~esm8
14 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Roundcube Webmail versions 1.6.17 and 1.7.2 and later. Users should upgrade to these or newer versions to remediate the vulnerability. No vendor advisory content was provided, but the version numbers indicate official fixes exist.

Description

Roundcube Webmail versions before 1.6.17 and 1.7.x before 1.7.2 contain a stored cross-site scripting (XSS) vulnerability. This occurs because the MIME type of attachments is not properly escaped on the attachment-validation warning page, allowing malicious scripts to be stored and executed in users' browsers. The vulnerability has a medium severity with a CVSS score of 4.7.

References

Community reviews

Loading reviews…