Skip to main content
VulnerabilityPublished Updated

CVE-2026-114724: Roundcube Webmail before 1.6.20 and 1.7.x before 1.7.5 contains an object injection primitive in

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-114724· High 7.4

Not known to be exploited · CVSS 7.4 High : upgrade to 1.7.5 or 1.6.20 soon.

Data as of 29 Oct 2026, 16:06 UTC

CVSS 3.1 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (mitre)CVSS 3.17.4
Patch
Available – fixed in 1.7.5, 1.6.20
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Webmail to 1.7.5 or 1.6.20.

Affected software

ProductAffectedFixed in
RoundcubeWebmailAffected
  • >=1.7.0 <1.7.5
Fixed in
  • 1.7.5
RoundcubeWebmailAffected
  • >=1.6.0 <1.6.20
Fixed in
  • 1.6.20
GitHubWebmailpkg:github/WebmailOther threatsAffected
  • >=1.6.0 <1.6.20
  • >=1.7.0 <1.7.5
Fixed in
  • 1.6.20
  • 1.7.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Roundcube Webmail to version 1.6.20 or later, or 1.7.5 or later, where the vulnerability has been fixed by rejecting session keys prefixed with “!”. No other mitigation is indicated as the fix is available and addresses the root cause.

Description

Roundcube Webmail versions before 1.6.20 and 1.7.x before 1.7.5 contain a vulnerability in the rcube_session::unserialize() function. This flaw allows an attacker who can influence stored session data to perform PHP object injection by exploiting how session keys prefixed with “!” are handled. The issue was fixed by rejecting such keys in a subsequent update.

References

Community reviews

Loading reviews…