CVE-2026-22726: Route Services can be leveraged to send app traffic to network destinations outside of an app's
Source GCVE Database
Not known to be exploited · CVSS 5.0 Medium : upgrade to v0.372.0 when convenient.
Data as of 27 Oct 2026, 00:34 UTC
- Patch
- Available – fixed in v0.372.0, v55.0.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 30 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Routing release to v0.372.0; CF Deployment to v55.0.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| CloudFoundry FoundationRouting release | Affected
| Fixed in
|
| CloudFoundry FoundationCF Deployment | Affected
| Fixed in
|
AI-suggested
Upgrade affected routing releases to v0.372.0 or later, or CF Deployment to v55.0.0 or later, which includes the fixed routing release. This official fix addresses the vulnerability by enforcing proper egress rule restrictions on route services. No other mitigation actions are specified.
Description
A vulnerability in Cloudfoundry's Route Services allows malicious developers to send application traffic to network destinations outside the app's configured egress rules. This can enable access to internal HTTP services reachable by the Gorouter that were not previously accessible from outside networks or the application itself. The issue affects routing releases from v0.118.0 through v0.371.0 and CF Deployment versions from v0.0.2 through v54.14.0. Upgrading to routing release v0.372.0 or CF Deployment v55.0.0 or later mitigates the vulnerability.