Skip to main content
CVE-2026-34826VulnerabilityPublished Updated

Ruby rack: Prior to versions 2.2.23, 3.1.21, and 3.2.6, Rack::Utils.get_byte_ranges parses the HTTP Range header

Affects ruby-rackSource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited · CVSS 7.5 High · fixed in 1.6.4-3ubuntu0.2+esm10 : patch ruby-rack soon.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.6.4-3ubuntu0.2+esm10, 1.6.4-4ubuntu0.2+esm10, 2.1.4-5ubuntu1.2+esm3 +2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=resoluteOther threatsAffected
  • 3.1.16-0.1 – 3.2.4-1ubuntu1
4 affected builds
Fixed in–
Ubuntu 25.10ruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=questingOther threatsAffected
  • <3.1.16-0.1ubuntu0.3
Fixed in
  • 3.1.16-0.1ubuntu0.3
Ubuntu 24.04 LTSruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=nobleOther threatsAffected
  • <2.2.7-1ubuntu0.7
Fixed in
  • 2.2.7-1ubuntu0.7
Ubuntu Pro 22.04 LTSruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=esm-apps/jammyOther threatsAffected
  • 2.1.4-5ubuntu1+esm2 – 2.1.4-5ubuntu1+esm5
  • <2.1.4-5ubuntu1.2+esm3
4 affected builds
Fixed in
  • 2.1.4-5ubuntu1.2+esm3
Ubuntu Pro 18.04 LTSruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=esm-apps/bionicOther threatsAffected
  • <1.6.4-4ubuntu0.2+esm10
Fixed in
  • 1.6.4-4ubuntu0.2+esm10
Ubuntu Pro 16.04 LTSruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=esm-apps/xenialOther threatsAffected
  • <1.6.4-3ubuntu0.2+esm10
Fixed in
  • 1.6.4-3ubuntu0.2+esm10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Rack is a modular Ruby web server interface. Prior to versions 2.2.23, 3.1.21, and 3.2.6, Rack::Utils.get_byte_ranges parses the HTTP Range header without limiting the number of individual byte ranges. Although the existing fix for CVE-2024-26141 rejects ranges whose total byte coverage exceeds the file size, it does not restrict the count of ranges. An attacker can supply many small overlapping ranges such as 0-0,0-0,0-0,... to trigger disproportionate CPU, memory, I/O, and bandwidth consumption per request. This results in a denial of service condition in Rack file-serving paths that process multipart byte range responses. This issue has been patched in versions 2.2.23, 3.1.21, and 3.2.6.

References

Community reviews

Loading reviews…