Skip to main content
CVE-2022-45442VulnerabilityPublished Updated

Ruby sinatra: Sinatra is a domain-specific language for creating web applications in Ruby

Affects ruby-sinatraSource GCVE Database

0

Not known to be exploited · CVSS 8.8 High : upgrade to 1.4.7-3ubuntu0.1~esm2 soon.

Data as of 26 Oct 2026, 08:30 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.4.7-3ubuntu0.1~esm2, 1.4.8-1ubuntu0.1~esm2, 2.0.8.1-2+deb11u1build0.22.04.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Nov 2022

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu ruby-sinatra to 1.4.7-3ubuntu0.1~esm2 (package) or 1.4.8-1ubuntu0.1~esm2 (package) or 2.0.8.1-2+deb11u1build0.22.04.1 (package).

Affected software

ProductAffectedFixed in
Ubuntu:Pro:16.04:LTSruby-sinatrapkg:deb/ubuntu/ruby-sinatra@1.4.7-3ubuntu0.1~esm2?arch=source&distro=esm-apps/xenialOther threatsAffected
  • <1.4.7-3ubuntu0.1~esm2
  • =1.4.6-2
  • =1.4.7-3
Fixed in
  • 1.4.7-3ubuntu0.1~esm2
Ubuntu:Pro:18.04:LTSruby-sinatrapkg:deb/ubuntu/ruby-sinatra@1.4.8-1ubuntu0.1~esm2?arch=source&distro=esm-apps/bionicOther threatsAffected
  • <1.4.8-1ubuntu0.1~esm2
  • =1.4.7-5
  • =1.4.8-1
Fixed in
  • 1.4.8-1ubuntu0.1~esm2
Ubuntu:22.04:LTSruby-sinatrapkg:deb/ubuntu/ruby-sinatra@2.0.8.1-2+deb11u1build0.22.04.1?arch=source&distro=jammyOther threatsAffected
  • <2.0.8.1-2+deb11u1build0.22.04.1
  • =2.0.8.1-2
Fixed in
  • 2.0.8.1-2+deb11u1build0.22.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Patches addressing this vulnerability are available in Sinatra versions 2.2.3 and 3.0.4. Users should upgrade to these or later versions to remediate the issue. No additional vendor advisory indicates alternative mitigations or that no action is required.

Description

Sinatra, a Ruby domain-specific language for web applications, has a vulnerability in versions before 2.2.3 and 3.0.4. The flaw allows a reflected file download (RFD) attack when the Content-Disposition header's filename is derived from user input. This vulnerability can impact confidentiality, integrity, and availability of affected systems. Versions 2.2.3 and 3.0.4 include patches that address this issue.

References

Community reviews

Loading reviews…