Skip to main content
VulnerabilityPublished Updated

CVE-2026-45784: rust-openssl provides OpenSSL bindings for the Rust programming language

Affects rust-opensslSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.1 High · fixed in 0.10.80 : patch rust-openssl soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.10.80
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10rust-opensslpkg:deb/ubuntu/rust-openssl?arch=source&distro=stonkingOther threatsAffected
  • =0.10.73-1
  • =0.10.81-1
Fixed in–
Ubuntu 26.04 LTSrust-opensslpkg:deb/ubuntu/rust-openssl?arch=source&distro=resoluteOther threatsAffected
  • =0.10.72-1
  • =0.10.73-1
Fixed in–
Ubuntu Pro 24.04 LTSrust-opensslpkg:deb/ubuntu/rust-openssl?arch=source&distro=esm-apps/nobleOther threatsAffected
  • =0.10.45-1
  • =0.10.57-1
  • =0.10.57-1ubuntu0.1~esm1
Fixed in–
Ubuntu Pro 22.04 LTSrust-opensslpkg:deb/ubuntu/rust-openssl?arch=source&distro=esm-apps/jammyOther threatsAffected
  • =0.10.29-1
  • =0.10.36-1
  • =0.10.36-1ubuntu0.1~esm1
Fixed in–
Ubuntu Pro 20.04 LTSrust-opensslpkg:deb/ubuntu/rust-openssl?arch=source&distro=esm-apps/focalOther threatsAffected
  • =0.10.23-1
  • =0.10.23-1ubuntu0.1~esm1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in rust-openssl version 0.10.80. Users should upgrade to version 0.10.80 or later to remediate this vulnerability. No other mitigation actions are specified.

Description

A vulnerability in rust-openssl versions from 0.10.50 up to but not including 0.10.80 causes incorrect sizing of output buffers in the CipherCtxRef::cipher_update_inplace function when used with AES key-wrap-with-padding ciphers. This leads to OpenSSL writing up to 7 bytes beyond the end of the caller's buffer or Vec for non-multiple-of-8 inputs, resulting in attacker-controllable heap corruption. The issue is fixed in version 0.10.80.

References

Community reviews

Loading reviews…