Rust wasmtime: Wasmtime before 36.0.16, 37.0.0 before 48.0.3, and 49.0.0 before 49.0.1 contains a denial of service
Affects rust-wasmtimeSource GCVE Database
Not known to be exploited · CVSS 6.9 Medium · fixed in 36.0.16 : update rust-wasmtime when convenient.
Data as of 28 Oct 2026, 23:12 UTC
- Patch
- Available – fixed in 36.0.16
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 22 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10rust-wasmtimepkg:deb/ubuntu/rust-wasmtime?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSrust-wasmtimepkg:deb/ubuntu/rust-wasmtime?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSrust-wasmtimepkg:deb/ubuntu/rust-wasmtime?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in rust-wasmtime versions 36.0.16, 48.0.3, and 49.0.1 and later. Users should upgrade to these or newer versions to remediate this denial of service vulnerability. No additional mitigation steps are indicated.
Description
A denial of service vulnerability exists in rust-wasmtime versions before 36.0.16, 37.0.0 before 48.0.3, and 49.0.0 before 49.0.1. The flaw is in wasmtime-wasi where guest WASI programs can cause the host to panic by overflowing filesystem timestamp fields. Specifically, attackers can pass atim or mtim values with sub-second fields that overflow the seconds field to certain filesystem time-setting functions, crashing the host process.
References
- ubuntu.com/security/CVE-2026-115387 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-115387 (opens in a new tab)
- github.com/bytecodealliance/wasmtime/security/advisories/GHSA-j2g9-4prp-pf6h (opens in a new tab)
- vulncheck.com/advisories/wasmtime-before-36.0.16-37.0.0-before-48.0.3-and-49.0.0-before-49.0.1-host-panic-via-wasi-filesystem-timestamp-overflow (opens in a new tab)