Skip to main content
VulnerabilityPublished

Rustls: Brotli certificate decompression can allocate an attacker-controlled amount of memory up to 1 GiB before

Affects rustlsSource GCVE Database

0

CVSS 3.7 Low : upgrade to 0.23.46 when convenient.

Data as of 27 Oct 2026, 17:42 UTC

CVSS 3.1 base score
3.7Low
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.23.46, 0.24.0-dev.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L

What to do

Upgrade rustls to 0.23.46; rustls to 0.24.0-dev.2.

Affected software

ProductAffectedFixed in
crates.iorustlsAffected
  • <0.23.46
Fixed in
  • 0.23.46
crates.iorustlsAffected
  • >=0.24.0-dev.1 <0.24.0-dev.2
Fixed in
  • 0.24.0-dev.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in rustls versions 0.23.46 and 0.24.0-dev.2. Users should upgrade to these or later versions to mitigate this vulnerability. If upgrading is not immediately possible, disabling the Brotli certificate decompression feature will prevent exploitation. No other mitigation is specified or required.

Description

Rustls contains a vulnerability in its Brotli certificate decompression feature, which is disabled by default. The Brotli decoder accepts an input-specified history window size that can be up to 1 GiB, potentially causing large memory allocations. This can lead to denial of service via memory exhaustion if a malicious peer sends specially crafted Brotli-encoded certificates. Both clients and servers enabling Brotli decompression and client authentication are affected. The issue is fixed in rustls versions 0.23.46 and 0.24.0-dev.2.

References

Community reviews

Loading reviews…