Skip to main content
VulnerabilityPublished Updated

CVE-2026-59884: Scoutsuite · pyasn1 BER/CER/DER decoder denial of service via unbounded long-form tag IDs

Affects scoutsuiteSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 5.14.0_15 soon.

Data as of 1 Nov 2026, 00:22 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.14.0_15
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade scoutsuite to 5.14.0_15.

Affected software

ProductAffectedFixed in
Homebrewscoutsuitepkg:brew/scoutsuiteOther threatsAffected
  • >=5.13.0 <5.14.0_15
Fixed in
  • 5.14.0_15

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in pyasn1 version 0.6.4 and later, which limits long-form tag IDs and hardens error handling. Users should upgrade to version 0.6.4 or newer. As a workaround, applications can bound the size of untrusted input passed to decode() to prevent excessive resource consumption.

Description

CVE-2026-59884 is a denial of service vulnerability in the pyasn1 library's BER/CER/DER decoders. The flaw arises from unbounded long-form tag IDs that cause excessive CPU consumption and can trigger unhandled exceptions on Python 3.11+. Applications decoding untrusted ASN.1 data with affected pyasn1 versions are vulnerable. The issue is fixed in pyasn1 version 0.6.4 and later.

References

Community reviews

Loading reviews…