Skip to main content
VulnerabilityPublished Updated

CVE-2024-6345: Scoutsuite · setuptools vulnerable to Command Injection via package URL

Affects scoutsuiteSource GCVE Database

0
Authoritative record:CVE-2024-6345· High 8.8

Not known to be exploited · CVSS 8.8 High : upgrade to 5.14.0_1 soon.

Data as of 26 Oct 2026, 19:00 UTC

CVSS 3.0 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.14.0_1
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Jul 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade scoutsuite to 5.14.0_1.

Affected software

ProductAffectedFixed in
Homebrewscoutsuitepkg:brew/scoutsuiteOther threatsAffected
  • >=5.13.0 <5.14.0_1
Fixed in
  • 5.14.0_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and the vulnerability is fixed in setuptools version 70.0. Users should upgrade to version 70.0 or later to remediate this issue. No additional mitigation steps are indicated beyond applying the official fix.

Description

CVE-2024-6345 is a high-severity vulnerability in the package_index module of pypa/setuptools up to version 69.1.1. It allows remote code execution via command injection through download functions that handle package URLs. This flaw can be exploited if user-controlled URLs are processed, enabling arbitrary command execution on the affected system. The vulnerability is fixed in setuptools version 70.0.

References

Community reviews

Loading reviews…