Skip to main content
VulnerabilityPublished

CVE-2026-16640: Search api autocomplete · This module enables you to add autocomplete suggestions for search forms

Affects drupal/search_api_autocompleteSource GCVE Database

0
Authoritative record:CVE-2026-16640· Medium 6.1

Not known to be exploited · CVSS 6.1 Medium : upgrade to 1.12.0 when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.12.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade drupal/search_api_autocomplete to 1.12.0.

Affected software

ProductAffectedFixed in
Packagist https //packages.drupal.org/8drupal/search_api_autocompleteAffected
  • <1.12.0
Fixed in
  • 1.12.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

This module enables you to add autocomplete suggestions for search forms created with the [Search API module](/project/search_api). The module ships with a test script that is accessible to anonymous users and doesn't sufficiently validate user input, leading to a Cross Site Scripting vulnerability. This vulnerability is mitigated by the fact that the web server must be configured to display warning messages to users.

References

Community reviews

Loading reviews…