Skip to main content
CVE-2026-39395VulnerabilityPublished Updated

SUSE cosign · Security update for cosign

Affects SUSE cosignSource GCVE Database

0
Compare
Authoritative record:CVE-2026-39395· Medium 4.3

Not known to be exploited · CVSS 4.3 Medium · fixed in SUSE package updates : update SUSE cosign when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.0.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
SUSEsuse/cosignpkg:rpm/suse/cosignOther threatsAffected
  • =3.0.6-150400.3.42.1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to cosign version 3.0.5 or later as provided by the SUSE Product Security Team. This update fixes the incorrect attestation verification issue. No additional mitigation steps are indicated.

Description

A security update for cosign addresses CVE-2026-39395, which involves incorrect attestation verification caused by malformed payloads or mismatched predicate types. This vulnerability could affect the integrity of attestation processes. The update also includes a non-security version upgrade to 3.0.5. The severity of this issue is assessed as medium.

References

Community reviews

Loading reviews…