Skip to main content
CVE-2025-4574VulnerabilityPublished Updated

SUSE gstreamer-devtools · Security update for gstreamer-devtools

Affects SUSE gstreamer-devtoolsSource GCVE Database

0
Compare

Mentioned vulnerabilities

Not known to be exploited : upgrade the affected SUSE packages to 1.26.7-160000.2.1 soon.

Data as of 31 Oct 2026, 20:20 UTC

Severity
High

Rated by Threat Radar · CVSS not yet scored by NVD

EPSS
0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.26.7-160000.2.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade the SUSE to 1.26.7-160000.2.1.

Affected software

ProductAffectedFixed in
SUSEsuse/gstreamer-devtoolspkg:rpm/suse/gstreamer-devtoolsOther threatsAffected
  • <1.26.7-160000.2.1
Fixed in
  • 1.26.7-160000.2.1
SUSEsuse/gstreamer-devtools-develpkg:rpm/suse/gstreamer-devtools-develOther threatsAffected
  • <1.26.7-160000.2.1
Fixed in
  • 1.26.7-160000.2.1
SUSEsuse/libgstvalidate-1_0-0pkg:rpm/suse/libgstvalidate-1_0-0Other threatsAffected
  • <1.26.7-160000.2.1
Fixed in
  • 1.26.7-160000.2.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing these issues has been released for gstreamer-devtools. Users should upgrade to version 1.26.7-160000.2.1 or later to mitigate these vulnerabilities. No additional vendor advisories indicate alternative mitigations or that no action is required.

Description

Multiple vulnerabilities have been identified and fixed in the gstreamer-devtools package by the SUSE Product Security Team. These include a race condition causing double-free and memory corruption, terminal manipulation via ANSI escape sequences, integer overflow leading to crashes, stack exhaustion from date parsing, process crashes from empty Range headers, and information disclosure from non-existing folder arguments. The issues affect versions prior to 1.26.7-160000.2.1. The severity of these combined issues is high.

References

Community reviews

Loading reviews…