Skip to main content
CVE-2026-25646VulnerabilityPublished Updated

SUSE · Security update for libpng12

Affects SUSESource GCVE Database

0
Compare
Authoritative record:CVE-2026-25646· High 8.3

Not known to be exploited · CVSS 8.3 High : upgrade SUSE to 1.6.55 soon.

Data as of 4 Nov 2026, 00:46 UTC

CVSS 4.0 base score
8.3High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.6.55
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:L/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade libpng to 1.6.55.

Affected software

ProductAffectedFixed in
pnggrouplibpngAffected
  • <1.6.55
Fixed in
  • 1.6.55

AI-suggested

Apply the security update provided by SUSE for libpng12 to remediate the heap buffer overflow vulnerability. Since this is an official fix, updating to the patched version is the recommended mitigation.

Description

A security update for libpng12 addresses a heap buffer overflow vulnerability in the png_set_dither and png_set_quantize functions. This flaw is identified as CVE-2026-25646 and was reported by the SUSE Product Security Team. The vulnerability could lead to memory corruption issues if exploited.

References

Community reviews

Loading reviews…