Skip to main content
CVE-2025-52194VulnerabilityPublished Updated

SUSE libsndfile · Security update for libsndfile

Affects SUSE libsndfileSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2025-52194· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade the SUSE suse/libsndfile package to 1.2.2-160000.4.1 soon.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.2.2-160000.4.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade the SUSE suse/libsndfile package to 1.2.2-160000.4.1.

Affected software

ProductAffectedFixed in
SUSEsuse/libsndfilepkg:rpm/suse/libsndfileOther threatsAffected
  • <1.2.2-160000.4.1
Fixed in
  • 1.2.2-160000.4.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official security update for libsndfile provided by the vendor to remediate these vulnerabilities. Since this is an official fix, updating to the patched version will resolve these issues. No additional mitigations are indicated by the vendor advisory.

Description

This security update for libsndfile addresses three vulnerabilities: a buffer overflow in the ircam_read_header function when processing malformed IRCAM audio files (CVE-2025-52194), a memory leak in the mpeg_l3_encoder_init() function (CVE-2025-56226), and an integer overflow in IMA-ADPCM processing (CVE-2026-37555). These issues could lead to potential memory corruption or resource exhaustion. The update fixes these issues to improve the security and stability of libsndfile.

References

Community reviews

Loading reviews…