Skip to main content
CVE-2026-1801VulnerabilityPublished Updated

SUSE libsoup2.4 · Security update for libsoup2

Affects SUSE libsoup2.4Source GCVE Database

0
Authoritative record:CVE-2026-1801· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium · fixed in Ubuntu package updates : update the affected Ubuntu packages when convenient.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.52.2-1ubuntu0.3+esm7, 2.62.1-1ubuntu0.4+esm8, 2.70.0-1ubuntu0.5+esm3 +5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu Pro 26.04 LTSlibsoup2.4pkg:deb/ubuntu/libsoup2.4?arch=source&distro=esm-apps/resoluteOther threatsAffected
  • <2.74.3-10.1ubuntu5+esm2
Fixed in
  • 2.74.3-10.1ubuntu5+esm2
Ubuntu 25.10libsoup2.4pkg:deb/ubuntu/libsoup2.4?arch=source&distro=questingOther threatsAffected
  • 2.74.3-10 – 2.74.3-10.1ubuntu4.1
7 affected builds
Fixed in–
Ubuntu 25.10libsoup3pkg:deb/ubuntu/libsoup3?arch=source&distro=questingOther threatsAffected
  • 3.6.5-1 – 3.6.5-4ubuntu0.2
6 affected builds
Fixed in–
Ubuntu 24.04 LTSlibsoup2.4pkg:deb/ubuntu/libsoup2.4?arch=source&distro=nobleOther threatsAffected
  • <2.74.3-6ubuntu1.8
Fixed in
  • 2.74.3-6ubuntu1.8
Ubuntu 24.04 LTSlibsoup3pkg:deb/ubuntu/libsoup3?arch=source&distro=nobleOther threatsAffected
  • <3.4.4-5ubuntu0.8
Fixed in
  • 3.4.4-5ubuntu0.8
Ubuntu 22.04 LTSlibsoup2.4pkg:deb/ubuntu/libsoup2.4?arch=source&distro=jammyOther threatsAffected
  • <2.74.2-3ubuntu0.8
Fixed in
  • 2.74.2-3ubuntu0.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

This update for libsoup2 fixes the following issues: - CVE-2026-1801: Use CRLF as line boundary when parsing chunk encoding data (bsc#1257649).

References

Community reviews

Loading reviews…