Skip to main content
CVE-2026-44988VulnerabilityPublished Updated

SUSE tightvnc · Security update for LibVNCServer

Affects SUSE tightvncSource GCVE Database

0
Authoritative record:CVE-2026-44988· High 8.8

Not known to be exploited · CVSS 8.8 High · fixed in Ubuntu package updates : patch the Ubuntu libvncserver package soon.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.9.13+dfsg-3ubuntu0.1, 0.9.14+dfsg-1ubuntu0.1, 0.9.15+dfsg-1ubuntu0.1 +1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.10tightvncpkg:deb/ubuntu/tightvnc?arch=source&distro=stonkingOther threatsAffected
  • =1:1.3.10-10build1
  • =1:1.3.10-11
Fixed in–
Ubuntu 26.10veyonpkg:deb/ubuntu/veyon?arch=source&distro=stonkingOther threatsAffected
  • 4.9.7+repack1-1.1 – 4.9.7+repack1-1build1
4 affected builds
Fixed in–
Ubuntu 26.10x11vncpkg:deb/ubuntu/x11vnc?arch=source&distro=stonkingOther threatsAffected
  • =0.9.17-2
  • =0.9.17-3
  • =0.9.17-3build1
Fixed in–
Ubuntu 26.04 LTSlibvncserverpkg:deb/ubuntu/libvncserver?arch=source&distro=resoluteOther threatsAffected
  • <0.9.15+dfsg-3ubuntu0.1
Fixed in
  • 0.9.15+dfsg-3ubuntu0.1
Ubuntu 26.04 LTStightvncpkg:deb/ubuntu/tightvnc?arch=source&distro=resoluteOther threatsAffected
  • =1:1.3.10-10
  • =1:1.3.10-10build1
Fixed in–
Ubuntu 26.04 LTSveyonpkg:deb/ubuntu/veyon?arch=source&distro=resoluteOther threatsAffected
  • =4.9.7+repack1-1
  • =4.9.7+repack1-1build1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

This update for LibVNCServer fixes the following issue - CVE-2026-44988: missing validation of rectangle width in tight gradient decoding can lead to server-triggered out-of- bounds write (bsc#1266459).

References

Community reviews

Loading reviews…