Skip to main content
CVE-2026-9698VulnerabilityPublished Updated

SUSE · Security update for perl-DBI

Affects SUSESource GCVE Database

0
Authoritative record:CVE-2026-9698· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade SUSE DBI to 1.648 soon.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.648
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade DBI to 1.648.

Affected software

ProductAffectedFixed in
HMBRANDDBIAffected
  • <1.648
Fixed in
  • 1.648
GitHubDBIpkg:github/DBIOther threatsAffected
  • <1.648
Fixed in
  • 1.648

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

This update for perl-DBI fixes the following issue - CVE-2026-9698: DBI versions before 1.648 for Perl saved errors in a limited-sized buffer (bsc#1267957).

References

Community reviews

Loading reviews…