Skip to main content
CVE-2024-2756VulnerabilityPublished Updated

SUSE · security update for php

Affects SUSESource GCVE Database

0
Compare
Authoritative record:CVE-2024-2756· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium · fixed in Debian package updates : update the Debian debian/php package when convenient.

Data as of 1 Nov 2026, 12:43 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (php)CVSS 3.16.5
Patch
Available – fixed in 8.4.0, 8.3.0, 8.2.0 +1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Apr 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade the Debian debian/php package to 8.4.0, 8.3.0, 8.2.0 or 8.1.0.

Affected software

ProductAffectedFixed in
Debiandebian/phppkg:deb/debian/phpOther threatsAffected
  • <8.1.0
  • <8.2.0
  • <8.3.0
  • <8.4.0
Fixed in
  • 8.1.0
  • 8.2.0
  • 8.3.0
  • 8.4.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The input does not specify patch availability or remediation details. Since this is a security update, it is implied that a fix is available. Users should consult the official SUSE and Red Hat advisories (specifically RHSA-2024:10949) for patching instructions and apply updates accordingly.

Description

This entry refers to a security update for PHP provided by the SUSE Product Security Team, which is functionally equivalent to Red Hat's advisory RHSA-2024:10949. The update addresses vulnerabilities identified under CVE-2024-2756 and related CVEs.

References

Community reviews

Loading reviews…