Skip to main content
CVE-2026-116891VulnerabilityPublished

SemanticMediaWiki from 4.2.0 before 7.2.1 contains a reflected cross-site scripting vulnerability that allows

Source GCVE Database

0
Authoritative record:CVE-2026-116891· Medium 5.1

Not known to be exploited · CVSS 5.1 Medium : upgrade to 7.2.1 when convenient.

Data as of 27 Oct 2026, 13:28 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 7.2.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade SemanticMediaWiki and semanticmediawiki/SemanticMediaWiki to 7.2.1.

Affected software

ProductAffectedFixed in
SemanticMediaWikiSemanticMediaWikiAffected
  • >=4.2.0 <7.2.1
Fixed in
  • 7.2.1
GitHubsemanticmediawiki/SemanticMediaWikipkg:github/semanticmediawiki/SemanticMediaWikiOther threatsAffected
  • >=4.2.0 <7.2.1
Fixed in
  • 7.2.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version exists starting from 7.2.1; users should upgrade SemanticMediaWiki to version 7.2.1 or later to remediate this vulnerability. No vendor advisory or patch links were provided in the input, so confirm patch availability from official SemanticMediaWiki sources before applying. Until patched, avoid clicking on untrusted URLs containing the vulnerable parameters.

Description

SemanticMediaWiki versions from 4.2.0 up to but not including 7.2.1 contain a reflected cross-site scripting (XSS) vulnerability. This flaw allows unauthenticated attackers to inject malicious HTML and execute scripts in users' browsers via crafted URLs targeting the Special:FacetedSearch page. The vulnerability arises from unescaped cstate parameters that break out of hidden input attributes. The CVSS 3.1 base score is 6.1, indicating a medium severity issue.

References

Community reviews

Loading reviews…