Skip to main content
CVE-2026-115754VulnerabilityPublished

Microsoft · serialize-javascript 7.0.1 before 7.1.3 XSS via unescaped </script in function body

Affects MicrosoftSource GCVE Database

0
Compare
Authoritative record:CVE-2026-115754· Low 2.3

Not known to be exploited · CVSS 2.3 Low : upgrade to 7.1.3 when convenient.

Data as of 29 Oct 2026, 10:37 UTC

CVSS 4.0 base score
2.3Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.02.3
CNA (VulnCheck)CVSS 3.14.7
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.1.3
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade serialize-javascript to 7.1.3.

Affected software

ProductAffectedFixed in
yahooserialize-javascriptAffected
  • >=7.0.1 <7.1.3
Fixed in
  • 7.1.3
npmserialize-javascriptpkg:npm/serialize-javascriptOther threatsAffected
  • >=7.0.1 <7.1.3
Fixed in
  • 7.1.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade serialize-javascript to version 7.1.3 or later where this vulnerability is fixed. Since no vendor advisory or patch links are provided, confirm patch availability from official sources before applying updates.

Description

A cross-site scripting (XSS) vulnerability exists in serialize-javascript versions 7.0.1 before 7.1.3 due to unescaped </script sequences in function bodies. This flaw could allow injection of malicious scripts when untrusted data is serialized and rendered in a web context.

References

Community reviews

Loading reviews…