CVE-2024-8635: GitLab · Server-Side Request Forgery (SSRF)
Affects gitlabSource GCVE Database
Not known to be exploited · fixed in 17.3.2 : patch gitlab soon.
Data as of 26 Oct 2026, 17:16 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 17.3.2, 17.2.5, 17.1.7
Exploitation evidence
Disclosed: evidence found.
CVE published 14 Sep 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade gitlab to 17.3.2, 17.2.5 or 17.1.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by upgrading GitLab EE to versions 17.1.7, 17.2.5, or 17.3.2 or later. Users should update affected installations promptly to remediate this vulnerability.
Description
A Server-Side Request Forgery (SSRF) vulnerability exists in GitLab Enterprise Edition versions starting from 16.8 up to but not including 17.1.7, from 17.2 up to but not including 17.2.5, and from 17.3 up to but not including 17.3.2. This flaw allows an attacker to make unauthorized requests to internal resources by exploiting a custom Maven Dependency Proxy URL.