Skip to main content
VulnerabilityPublished Updated

CVE-2026-59085: Apache CloudStack's webhook module, exploitable · Server-Side Request Forgery (SSRF) Vulnerability

Source GCVE Database

0
Authoritative record:CVE-2026-59085· Critical 9.1

Not known to be exploited · CVSS 9.1 Critical · fixed in 4.20.3.1 : patch Apache CloudStack as a priority.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.20.3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache CloudStackAffected
  • >=4.20.0.0 <=4.20.3.0
  • >=4.21.0.0 <=4.22.1.0
Fixed in–
Mavenorg.apache.cloudstack/cloudstackpkg:maven/org.apache.cloudstack/cloudstackOther threatsAffected
  • =4.20.0.0
  • >=4.20.0.0 <=4.20.3.0
  • =4.21.0.0
  • >=4.21.0.0 <=4.22.1.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Server-Side Request Forgery (SSRF) vulnerability in Apache CloudStack's webhook module, exploitable via webhook delivery requests. This issue affects Apache CloudStack: from 4.20.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0. Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.

References

Community reviews

Loading reviews…