sdist · setuptools: MANIFEST.in exclusion bypass
Affects ccmSource GCVE Database
Not known to be exploited · CVSS 6.1 Medium : upgrade to 3.1.5_6 when convenient.
Data as of 26 Oct 2026, 19:43 UTC
- Patch
- Available – fixed in 3.1.5_6
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade ccm to 3.1.5_6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewccmpkg:brew/ccmOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in setuptools version 3.1.5_6. Users should upgrade to this version or later to ensure that both MANIFEST.in patterns and on-disk filenames are normalized to a canonical Unicode form before matching, preventing exclusion bypass. Until upgrading, maintainers should be aware that MANIFEST.in exclusions may not work correctly for non-ASCII filenames on macOS APFS/HFS+ filesystems.
Description
A Unicode normalization mismatch in setuptools' handling of MANIFEST.in exclusions can cause files intended to be excluded from source distributions to be included instead. This occurs because on macOS APFS/HFS+ filesystems, filenames are stored in NFD form, but MANIFEST.in patterns are typically written in NFC form, leading to a byte-level mismatch during exclusion matching. As a result, sensitive files with non-ASCII names may be unintentionally published to PyPI. The issue affects setuptools versions prior to 3.1.5_6 and has been fixed in 3.1.5_6.
References
- github.com/pypa/setuptools/security/advisories/GHSA-h35f-9h28-mq5c (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-59890 (opens in a new tab)
- github.com/pypa/setuptools/commit/dd9f436a36486b4cb8a4c70a2321548b0be09b8f (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/setuptools/PYSEC-2026-3447.yaml (opens in a new tab)
- github.com/pypa/setuptools (opens in a new tab)
- github.com/pypa/setuptools/releases/tag/v83.0.0 (opens in a new tab)