Skip to main content
VulnerabilityPublished Updated

CVE-2024-6345: setuptools vulnerable to Command Injection via package URL

Affects setuptoolsSource GCVE Database

0
Compare
Authoritative record:CVE-2024-6345· High 8.8

Not known to be exploited · CVSS 8.8 High : upgrade to 70.0.0 soon.

Data as of 4 Nov 2026, 17:27 UTC

CVSS 3.0 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 70.0.0
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Jul 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade setuptools to 70.0.0.

Affected software

ProductAffectedFixed in
PyPIsetuptoolsAffected
  • <70.0.0
Fixed in
  • 70.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade setuptools to version 70.0.0 or later, where this vulnerability is fixed. No other mitigations are specified or required once the patch is applied.

Description

A command injection vulnerability exists in the package_index module of setuptools versions prior to 70.0.0. This flaw allows remote code execution via download functions that process package URLs, which if user-controlled, can lead to arbitrary command execution. The issue is fixed in setuptools version 70.0.0.

References

Community reviews

Loading reviews…