CVE-2025-12761: Simple multistep · This module provides the ability to convert any entity form into a simple
Affects drupal/simple_multistepSource GCVE Database
Not known to be exploited · CVSS 3.5 Low : upgrade to 2.0.0 when convenient.
Data as of 4 Nov 2026, 18:11 UTC
- Patch
- Available – fixed in 2.0.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 18 Nov 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade drupal/simple_multistep to 2.0.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Packagist https //packages.drupal.org/8drupal/simple_multistep | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade the Simple multistep module to version 2.0.0 or later, where the vulnerability is fixed. Since a patch is available, applying this official fix is the recommended remediation.
Description
The Simple multistep module for Drupal allows converting any entity form into a simple multi-step form. A cross-site scripting (XSS) vulnerability exists due to insufficient filtering of certain user-provided text. Exploitation requires the attacker to have the 'administer node form display' permission, limiting the attack surface. A fix is available in version 2.0.0.