Skip to main content
VulnerabilityPublished Updated

CVE-2026-42215: Snakemake · GitPython has Command Injection via Git options bypass

Affects snakemakeSource GCVE Database

0
Authoritative record:CVE-2026-42215· High 8.8

Not known to be exploited · CVSS 8.8 High : upgrade to 9.20.0 soon.

Data as of 26 Oct 2026, 19:31 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 9.20.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade snakemake to 9.20.0.

Affected software

ProductAffectedFixed in
Homebrewsnakemakepkg:brew/snakemakeOther threatsAffected
  • >=7.20.0 <9.20.0
Fixed in
  • 9.20.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Snakemake to version 9.20.0 or later, where this vulnerability is fixed. The patch corrects the unsafe option validation to properly handle underscore-form kwargs. No other mitigation is required as the fix addresses the root cause.

Description

GitPython, as used in Snakemake versions 7.20.0 up to but not including 9.20.0, contains a command injection vulnerability (CVE-2026-42215). This occurs because unsafe Git options such as --upload-pack and --receive-pack are blocked by name, but their equivalent Python keyword arguments with underscores (upload_pack, receive_pack) bypass this check and allow arbitrary command execution. The vulnerability affects methods like Repo.clone_from(), Remote.fetch(), Remote.pull(), and Remote.push() when attacker-controlled kwargs are passed. A fix is available in version 9.20.0.

References

Community reviews

Loading reviews…