CVE-2026-114145: Snakemake · GitPython validates a submodule's ".git" path only after cloning into it (RCE)
Affects snakemakeSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 9.27.1 soon.
Data as of 26 Oct 2026, 19:31 UTC
- Patch
- Available – fixed in 9.27.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 21 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade snakemake to 9.27.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewsnakemakepkg:brew/snakemakeOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in Snakemake version 9.27.1 that fixes this vulnerability. Users should upgrade to version 9.27.1 or later. Prior to upgrading, avoid passing untrusted or attacker-influenced paths to create_submodule, especially paths that could point to .git directories or hooks. Note that in versions 3.2.0 and later, although a ValueError is raised when an invalid path is detected, the malicious hook may already have been planted, so relying on catching this exception is insufficient. Upgrading to the fixed version is the recommended remediation.
Description
Snakemake's use of GitPython allows an attacker to execute arbitrary code by creating a submodule with a path that points to the .git/hooks directory. This causes an attacker-controlled executable hook to be planted and run on subsequent git operations. Versions from 5.5.3 up to but not including 9.27.1 are affected. Although versions 3.2.0 and later raise a ValueError after cloning, the malicious hook remains on disk and executable. This vulnerability enables remote code execution if an attacker can influence the submodule path parameter.
References
- github.com/gitpython-developers/GitPython/security/advisories/GHSA-83vg-56qc-22m7 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-114145 (opens in a new tab)
- github.com/gitpython-developers/GitPython/pull/2264 (opens in a new tab)
- github.com/gitpython-developers/GitPython/commit/97eadb888d2f99567e3113f4e455be4ca128f697 (opens in a new tab)
- github.com/gitpython-developers/GitPython (opens in a new tab)
- github.com/gitpython-developers/GitPython/releases/tag/3.2.1 (opens in a new tab)