CVE-2025-6965: Sqlite3 · There exists a vulnerability in SQLite versions before 3.50.2 where the number of aggregate
Affects sqlite3Source GCVE Database
Public exploit available (Exploit-DB) · CVSS 7.7 High · fixed in 3.8.2-1ubuntu2.2+esm5 : patch sqlite3 as a priority.
Data as of 27 Oct 2026, 06:42 UTC
- Patch
- Available – fixed in 3.8.2-1ubuntu2.2+esm5, 3.11.0-1ubuntu1.5+esm3, 3.22.0-1ubuntu0.7+esm2 +4
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:H/A:LExploitation evidence
t = 0 is the CVE’s publication on cve.org
Disclosed: evidence found.
CVE published 15 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: evidence found.
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
Timeline
CVE published
on cve.org
, t = 0
First Exploit-DB entry (opens in a new tab)
SQLite 3.50.1 - Heap Overflow
, 267 days after disclosure
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10sqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSsqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 22.04 LTSsqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Ubuntu Pro 20.04 LTSsqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in
|
Ubuntu Pro 18.04 LTSsqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=esm-infra/bionicOther threats | Affected
| Fixed in
|
Ubuntu Pro 16.04 LTSsqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=esm-infra/xenialOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
There exists a vulnerability in SQLite versions before 3.50.2 where the number of aggregate terms could exceed the number of columns available. This could lead to a memory corruption issue. We recommend upgrading to version 3.50.2 or above.