Skip to main content
VulnerabilityPublished Updated

CVE-2026-61642: Squid3 · Squid is a caching proxy for the Web

Affects squid3Source GCVE Database

0
Compare
Authoritative record:CVE-2026-61642· High 7.7

Not known to be exploited · CVSS 7.7 High · fixed in 3.5.12-1ubuntu7.16+esm7 : patch squid3 soon.

Data as of 2 Nov 2026, 22:58 UTC

CVSS 3.1 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
2.0% chance of exploitation in 30 days – higher than 81% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.5.12-1ubuntu7.16+esm7, 3.5.27-1ubuntu1.14+esm6, 4.10-1ubuntu1.13+esm3 +2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSsquidpkg:deb/ubuntu/squid?arch=source&distro=resoluteOther threatsAffected
  • 6.13-1ubuntu4 – 7.7-0ubuntu0.26.04.1
6 affected builds
Fixed in–
Ubuntu 24.04 LTSsquidpkg:deb/ubuntu/squid?arch=source&distro=nobleOther threatsAffected
  • <6.14-0ubuntu0.24.04.5
Fixed in
  • 6.14-0ubuntu0.24.04.5
Ubuntu 22.04 LTSsquidpkg:deb/ubuntu/squid?arch=source&distro=jammyOther threatsAffected
  • <5.9-0ubuntu0.22.04.8
Fixed in
  • 5.9-0ubuntu0.22.04.8
Ubuntu Pro 20.04 LTSsquidpkg:deb/ubuntu/squid?arch=source&distro=esm-infra/focalOther threatsAffected
  • <4.10-1ubuntu1.13+esm3
Fixed in
  • 4.10-1ubuntu1.13+esm3
Ubuntu Pro 18.04 LTSsquid3pkg:deb/ubuntu/squid3?arch=source&distro=esm-infra/bionicOther threatsAffected
  • <3.5.27-1ubuntu1.14+esm6
Fixed in
  • 3.5.27-1ubuntu1.14+esm6
Ubuntu Pro 16.04 LTSsquid3pkg:deb/ubuntu/squid3?arch=source&distro=esm-infra-legacy/xenialOther threatsAffected
  • <3.5.12-1ubuntu7.16+esm7
Fixed in
  • 3.5.12-1ubuntu7.16+esm7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and has been released in Squid version 7.6. Ubuntu has provided updated package versions for all affected LTS releases, including 16.04, 18.04, 20.04, 22.04, and 24.04. Users should update their Squid installations to the patched versions as provided by their distribution to remediate this vulnerability. Standard system updates on Ubuntu will apply these fixes. No additional mitigation steps are required beyond applying the official patches.

Description

Squid versions from 3.3.0.1 up to but not including 7.6 contain a vulnerability in HTTP/1.1 Transfer-Encoding header parsing that allows a trusted client to perform HTTP Request Smuggling attacks. This flaw arises from improper enforcement of HTTP specifications regarding the Transfer-Encoding header, enabling attackers to bypass security mechanisms and potentially poison upstream web caches. The issue is fixed in Squid version 7.6. Ubuntu has released patches for multiple affected versions across various LTS releases.

References

Community reviews

Loading reviews…