Skip to main content
VulnerabilityPublished

CVE-2026-118576: Stage file proxy · It is not intended for usage on production sites

Affects drupal/stage_file_proxySource GCVE Database

0

Not known to be exploited : upgrade to 4.0.1 or 3.1.7 when convenient.

Data as of 28 Oct 2026, 20:30 UTC

Severity
Medium

Rated Medium by Threat Radar's AI analysis · CVSS not yet scored by NVD

Patch
Available – fixed in 4.0.1, 3.1.7

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade drupal/stage_file_proxy to 4.0.1 or 3.1.7.

Affected software

ProductAffectedFixed in
Packagist https //packages.drupal.org/8drupal/stage_file_proxyAffected
  • <3.1.7
  • >=4.0.0 <4.0.1
Fixed in
  • 3.1.7
  • 4.0.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading to Stage File Proxy versions 3.1.7 or 4.0.1 or later. Avoid enabling the Stage File Proxy module on production sites, as it is intended only for development environments. No additional mitigation is required beyond patching and proper module usage.

Description

Stage File Proxy is a Drupal module designed to fetch production files on development servers. It is not intended for use on production sites. A vulnerability exists due to insufficient validation of file URLs during fallback retrieval, leading to a cross-site scripting (XSS) vulnerability. Exploitation requires the module to be enabled on the target site and the attacker to have the ability to upload a malicious file to the configured origin server. Fixed versions 3.1.7 and 4.0.1 address this issue.

References

Community reviews

Loading reviews…