CVE-2026-48817: Starlette · Arbitrary HTTP method dispatched to `HTTPEndpoint` attributes via `getattr`
Affects glancesSource GCVE Database
Not known to be exploited · CVSS 5.3 Medium : upgrade to 4.5.5 when convenient.
Data as of 1 Nov 2026, 01:38 UTC
- Patch
- Available – fixed in 4.5.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 17 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade glances to 4.5.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewglancespkg:brew/glancesOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Register HTTPEndpoint subclasses with an explicit methods= argument on the Route, listing only the supported HTTP verbs. This causes the route to reject non-standard methods with a 405 Method Not Allowed response before reaching the endpoint, preventing unauthorized attribute invocation. Additionally, upgrade affected versions to 4.5.5 or later where the issue is fixed.
Description
Starlette's HTTPEndpoint dispatches HTTP methods by lowercasing the method name and using getattr without restricting to known HTTP verbs. If an HTTPEndpoint subclass is registered via Route without specifying allowed methods, non-standard HTTP methods can invoke internal attributes as handlers. This can lead to unauthorized invocation of internal methods. The issue affects Starlette and frameworks built on it, such as FastAPI. The vulnerability is patched in version 4.5.5.