Skip to main content
VulnerabilityPublished Updated

CVE-2024-27280: StringIO buffer overread vulnerability

Affects stringioSource GCVE Database

0
Compare
Authoritative record:CVE-2024-27280· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical : upgrade to 3.0.1.1 as a priority.

Data as of 4 Nov 2026, 17:27 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.19.8
Patch
Available – fixed in 3.0.1.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade stringio to 3.0.1.1.

Affected software

ProductAffectedFixed in
RubyGemsstringioAffected
  • <3.0.1.1
Fixed in
  • 3.0.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available. Users should update the StringIO gem to version 3.0.1.1 or later. For Ruby 3.0 users, update to stringio 3.0.1.1; for Ruby 3.1 users, update to stringio 3.1.0.2. Use `gem update stringio` or add `gem "stringio", ">= 3.0.1.2"` to your Gemfile if using bundler. Ruby 3.2.x and later versions are not affected.

Description

CVE-2024-27280 is a critical buffer overread vulnerability in the StringIO Ruby gem versions prior to 3.0.1.1. The flaw allows the ungetbyte and ungetc methods to read past the end of a string, potentially causing subsequent calls to StringIO.gets to return unintended memory contents. This issue affects Ruby 3.0.x through 3.0.6 and 3.1.x through 3.1.4. The vulnerability is fixed in StringIO 3.0.1.1 and later, and Ruby 3.2.x and later are not affected.

References

Community reviews

Loading reviews…