Skip to main content
VulnerabilityPublished Updated

CVE-2026-63762: SurrealDB before v2.6.1 (and before v3.0.0-beta.3) contains a denial of service vulnerability in its embedded JavaScript scripting engine, which is

Affects surrealdbSource GCVE Database

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.6.1 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.6.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade surrealdb/surrealdb to 2.6.1.

Affected software

ProductAffectedFixed in
GitHubsurrealdb/surrealdbpkg:github/surrealdb/surrealdbOther threatsAffected
  • <2.6.1
Fixed in
  • 2.6.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available by upgrading SurrealDB to version 2.6.1 or later, or 3.0.0-beta.3 or later, which includes the updated rquickjs dependency (v0.11.0). Until patched, avoid enabling the --allow-scripting option or restrict query execution to trusted users only. Monitor vendor advisories for official patches and updates.

Description

SurrealDB versions before 2.6.1 and before 3.0.0-beta.3 contain a denial of service vulnerability in their embedded JavaScript scripting engine. This vulnerability is triggered when the --allow-scripting option is enabled, which is disabled by default. An attacker able to execute arbitrary queries, including unauthenticated guests if --allow-guests is enabled, can cause the server to crash by exploiting a null pointer dereference in the QuickJS-NG engine. The issue requires manual server restart after the crash. The vulnerability was fixed by updating the rquickjs dependency to version 0.11.0.

References

Community reviews

Loading reviews…