Skip to main content
CVE-2026-123567VulnerabilityPublished

Sveltejs devalue before 5.6.4 contains a prototype injection vulnerability that allows attackers to inject __proto__

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-123567· Medium 6.3

Not known to be exploited · CVSS 6.3 Medium : upgrade to 5.6.4 when convenient.

Data as of 8 Nov 2026, 06:36 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.06.3
CNA (VulnCheck)CVSS 3.13.7
Patch
Available – fixed in 5.6.4
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.

What to do

Upgrade devalue to 5.6.4.

Affected software

ProductAffectedFixed in
sveltejsdevalueAffected
  • <5.6.4
Fixed in
  • 5.6.4
npmdevaluepkg:npm/devalueOther threatsAffected
  • <5.6.4
Fixed in
  • 5.6.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Sveltejs devalue version 5.6.4. Users should upgrade to version 5.6.4 or later to remediate this vulnerability. No other mitigation steps are indicated by the vendor advisory or source data.

Description

Sveltejs devalue versions before 5.6.4 have a prototype injection vulnerability. This flaw allows attackers to inject __proto__ properties into objects returned by devalue.parse and devalue.unflatten. If downstream code merges these objects using Object.assign, the prototype of the target object can be altered. The vulnerability has a low severity score of 3.7 and does not impact confidentiality or availability but can cause integrity issues.

References

Community reviews

Loading reviews…