Sveltejs devalue from 1.0.0 before 5.9.3 contains a memory exhaustion flaw in uneval, whose generated code for sparse
Source GCVE Database
Not known to be exploited · CVSS 8.7 High : upgrade to 5.9.3 soon.
Data as of 8 Nov 2026, 06:36 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 8.7 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 7.5 |
- Patch
- Available – fixed in 5.9.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.
What to do
Upgrade devalue to 5.9.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| sveltejsdevalue | Affected
| Fixed in
|
npmdevaluepkg:npm/devalueOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, avoid processing or accepting untrusted large sparse arrays in serialized data to reduce risk.
Description
Sveltejs devalue versions from 1.0.0 up to but not including 5.9.3 contain a memory exhaustion vulnerability in the uneval function. The flaw arises because the generated code for sparse arrays allocates memory proportional to the declared length of the array when evaluated. An attacker who can control a very large sparse array serialized by an application could cause memory exhaustion in the browser or runtime environment processing the output.