Skip to main content
CVE-2026-45073VulnerabilityPublished

Symfony: Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, PdoAdapter::doClear() builds a DELETE statement using a

Affects symfonySource GCVE Database

0

Not known to be exploited · CVSS 7.3 High · fixed in 5.4.52 : patch symfony soon.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.4.52
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10symfonypkg:deb/ubuntu/symfony?arch=source&distro=stonkingOther threatsAffected
  • 7.4.7+dfsg-1ubuntu1 – 7.4.16+dfsg-1ubuntu2
6 affected builds
Fixed in–
Ubuntu 26.04 LTSsymfonypkg:deb/ubuntu/symfony?arch=source&distro=resoluteOther threatsAffected
  • 6.4.24+dfsg-1 – 7.4.7+dfsg-1ubuntu1
4 affected builds
Fixed in–
Ubuntu 25.10symfonypkg:deb/ubuntu/symfony?arch=source&distro=questingOther threatsAffected
  • 6.4.18+dfsg-1ubuntu1 – 6.4.24+dfsg-1
4 affected builds
Fixed in–
Ubuntu Pro 24.04 LTSsymfonypkg:deb/ubuntu/symfony?arch=source&distro=esm-apps/nobleOther threatsAffected
  • 5.4.23+dfsg-1ubuntu1 – 6.4.5+dfsg-3ubuntu3+esm1
5 affected builds
Fixed in–
Ubuntu Pro 22.04 LTSsymfonypkg:deb/ubuntu/symfony?arch=source&distro=esm-apps/jammyOther threatsAffected
  • =5.2.6+dfsg-1ubuntu7
  • =5.4.4+dfsg-1ubuntu8
  • =5.4.4+dfsg-1ubuntu8+esm1
Fixed in–
Ubuntu Pro 20.04 LTSsymfonypkg:deb/ubuntu/symfony?arch=source&distro=esm-apps/focalOther threatsAffected
  • 4.3.4+dfsg-1ubuntu1 – 4.3.8+dfsg-1ubuntu1+esm2
4 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The vulnerability is fixed in Symfony versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12. Users should upgrade to these or later versions to remediate the issue. No additional mitigation steps are indicated.

Description

CVE-2026-45073 is a vulnerability in the Symfony PHP framework affecting versions prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12. It allows an attacker who can control the $prefix parameter in the PdoAdapter::doClear() function to manipulate the DELETE SQL statement by exploiting improper binding or escaping of the namespace derived from $prefix. This can alter the semantics or scope of the deletion query. The issue has been fixed in the specified versions.

References

Community reviews

Loading reviews…